MODパックサーバーが起動しない ~権限編~

公開日: 2026/9/6


ご相談者様

匿名希望

ご相談内容

MODパック「ATM9」サーバーが起動しない!

環境

さくらのゲームサーバー
Forgeテンプレート 16GB


さて、今回もお困りの方を見つけてしまいました(義務)

内容は上記の通りでございますが、ただのMODサーバーではありません。
“MODパック” なんですよね。

まあ、まず最初はConoha特有のトラブルかと疑いました。
そうです、MODのアップロードができない、でした。これについては、前回のヘルプデスクをご覧いただければと思います。

せっかく「Mine and Slash」と「Dungeon Realm」で建てたMODサーバーが起動しない!


まあまあ、アップロードできない問題は、例によってSSHで解決できたとして…
なぜこんなに苦戦したのかというと、MODが全部で400個オーバーだったからです。

該当のMODパックは「ATM9」というものでした。
ATM9配布サイトはこちら

こんな量のMODのサーバー構築したことねえよ…と思いながらご相談をお伺いしました(怒ってないよ笑)。
最初は「シンプルに時間がかかるのかな~やっぱ400個はきついか~」なんて安直に考えました。

まあ、とりあえずの精神でlogを読んでみます。

しばらく起動させながら眺めても、エラーは出ていないし変なところはなさそうですが、debug.logが途中から一切更新されないみたいでした。
ただ、crash.logは生成されていないので、明示的なエラーではないようです。

本当にサーバー起動頑張っているのか…?と、疑念が出てきました。

とりあえずtopでプロセス一覧を見ることに。 javaが動いているので起動中ではあるが、不自然すぎるほどCPUやメモリ使用率がほぼ0%張り付き。
さすがにおかしいか?いやでも、プロセスは生きている…

詳細を確認するためにps auxをjavaプロセスで絞ってみると、結果はS+。
これはプロセスがイベントの発生を待ってスリープしている状態らしいです。当時はこれが原因か…?と疑っていたのですが、後日検証したところ、Minecraftサーバーは起動の最中だろうが、起動中であろうがS+であるらしいです。なので、これは直接的な原因ではない、と後日談として学びました。

では、さらに検証をしていきましょう。logをとにかく追います。

すると、「travelersbackpack」でログ出力が止まっていることに気が付きました。これに気が付いたときは、これじゃ~ん、と意気揚々としていました。
ここで考えられるのは「travelersbackpack」のロードで止まっているのか、その次に読み込むであろうMOD(ごめんなさい名前忘れました)の読み込む準備でループしたか…

MODパックで競合することは考えにくいので、それぞれのjarファイルが死んでいないか確認することに。

・MODなし
・travelersbackpack単体
・名前忘れたMOD単体

この3パターンでサーバーを起動させることに。
しかし、結果は全部無事起動…jarファイルは正常、ということになりました。

じゃあ、メモリが追いつけなくなってループでもしてるか…?と思い、念のため起動構成である「ser_jvm_args.txt」を以下のブログを参考に編集。
(ありがとう、過去の自分)。

【Minecraft】大量のBotを使ってG1GCの最高の設定を探ってみる

しかし、これも効果なし。
いよいよです、手札が尽きました。

しかし、色々と調べてる間にも起動をあきらめず待機していると、ログが動きました。

Failed to write AE2 config

おっ?これは…!?
そしてさらに見ていくと…「permission」の文字が。



キタ━━━━(゚∀゚)━━━━!!

ってやつですね。権限あげましょう。

と、思いましたが「ファイルの所有者あんたやないんかい!」
rootでログインしてるからいけるやん!と思ったので、すぐに落胆することに。

いや、まてよ…

「線状降水帯…うっ・・・!!」

ちゃうちゃう




でん:このプロセスの実行者は誰だ…?ログイン者は確かにrootだ。
でん:だが、マイクラサーバーを起動させる時の操作は、Conohaのコンソールだ。

でん:つまり、javaプロセスの実行者がrootである確証はない!
でん:ハヤト!topコマンドを実行してくれ。マイクラサーバーの実行者の確認を!

ハヤト:OK!・・・予想的中、マイクラサーバーの実行者は「minecraft」というユーザーだ。

でん:やはりか…ハヤト!WinSCPで該当のファイルの所有者と権限を確認。

ハヤト:了解!所有者はroot、権限は「rw-rw-r—」。
ハヤト:所有者、もしくは所有者と同じグループに所属するユーザーでないと、このファイルは書き込みができない!

でん:さっきのログは…

Failed to write AE2 config




はいもうここで皆さんの頭にはVIVANTのテーマソングが流れましたね、おめでとうございます。ありがとうございます。

茶番はこの辺にしますが、書いたことは間違いないです。これが原因です。

では、権限を…もしくは所有者の変更でもいいですね。
今回はマイクラサーバーのデータが入っているフォルダの所有者を、javaプロセスの実行者である「minecraft」にしちゃいましょう。

sudo chown -R minecraft <ファイルパス>

実行後、WinSCPで所有者を確認。
ちゃんとminecraftが所有者になりました。

さあ、改めて…サーバー起動し、待つこと5分

Done!
 :
Can't keep up!

いつものログとともに、ほっと安堵しました。

ログイン確認もでき、これにて解決。
ほんとによかった!

長丁場、2時間弱…お待たせいたしました。
ご相談者様にはお時間とってしまいすみません、って感じです…。
また、困ったらいつでも言ってくださいね!僕でよければ相談、乗ります!


🐌 最後に:サーバーの困ったを解決します!

皆でマイクラしたいけど、よくわかんなくてできないよ~;;って人はとりあえず僕に声かけてみてください!今回みたいに長丁場になるかもですが解決できるかもです!

下記から気軽にご相談くださいませm(__)m

Mail : 2dendendend2@gmail.com
X:dendend12345
Discord : dendend12345
※Discordでご連絡の場合は、フレンド申請とともにメッセージ送信もお願いいたします。

※この記事は、ご相談者様の許可を頂いて掲載をしております。